Trident "job still pending execution"

Feb 10, 2012 at 2:25 AM
Edited Feb 10, 2012 at 6:49 AM

Dear all,

I've tried to run the Trident samples Cove and Ocean current, each time its a really long wait and the message appears "A job is still pending for execution, do you want to continue waiting..".

I've installed the standalone config of Trident. Visual Studio 2010 Professional (with .NET 4), SQL Server 2008 Express.

I checked if its connected to the SQL Server  via- Workflow Composer -> Connection Tab- > Advanced - > Test Connection and it returns connection successfully established.

I'm not sure what's happening.

I'm also trying to add the dll System.Workflow.ComponentModel. Working through the documentation - Quickstart and Programming guide.  I found its location in Program Files/ Referenced Assemblies/ Microsoft/,NET Framework/v4.0 added it by right clicking the solution's references-> Add.  Although each time a yellow exclamation mark icon appears.

 

Thanks.

Feb 10, 2012 at 10:02 AM
Edited Feb 10, 2012 at 10:04 AM

Hi,

Thanks for showing interest in Trident.

I cannot reproduce the error at my end. The Cove Sample is working fine on my test machine and getting completed with seconds.

The Ocean Current sample runs fine, but to let the job completed you need to close the modal less (gets hidden behind other active windows. when you minimize other windows you will see this "Chart" window that was created by the Ocean current job. Here are few screen shots) In my starting days I had got confused because of this but not sure with your case. If this is not the case with you then please send me the screen shot of the msg. Make sure that the staring time and job execution infos are visible in the screen shot.

2nd issue

This could be because of project type mismatch. Make sure your application is targated to .NET 4 and not .NET 4 Client profile. To check it right click the project --> Choose properties --> Check the target framework combo box and set it to .NET 4 if it set to other.

Please let me know if this helps you in resolving your query or any further query.

-Regards

 

  

Feb 14, 2012 at 2:38 AM

Thanks for your reply.

After a restart Issue 1 was resolved, both the Ocean Current and Cove examples are now working. Your suggestion for Issue 2 solved the problem!