Installation using build\full.cmd

Jul 19, 2010 at 5:16 AM
I was trying the tridentworkflow-62345\build\full.cmd script. When I ran it on a machine with Visual Studio 2010 Ultimate and .NET Framework 4.0 Extended/Client Profile/Multi-targeting installed. The script checks the system but assumes the MSBUILD_4_0 variable. If this variable is not set then the installation fails (atleast for me). Worst part is installation fails without telling why it failed or how it can be corrected. It is upto the user to read the script and console.out to figure out the missing parts. The installation fails with #call Datalayer.sln /t:rebuild /fileLoggerParameters:LogFile=Datalayer.log /p:O utDir=\\ /p:Configuration= 'Datalayer.sln' is not recognized as an internal or external command, operable program or batch file. The reason for this failure is MSBUILD_4_0 variable is not set. My command line: #echo %MSBUILD_4_0% %MSBUILD_4_0% Note: Line 18 needs to be instead of pushd ..\trident\product\DataLayer instead of pushd .\trident\product\DataLayer Similarly line 18, 37, 53, 72, 134 need to be ..\ instead of .\ Line 102, 146 should be ..\trident instead of trident Thanks, Ashish Bhangale
Jul 19, 2010 at 5:17 AM
Suggest me what the value for this variable should be set to ?
Jul 19, 2010 at 5:20 AM
Edited Jul 19, 2010 at 5:22 AM
I see that the file path being referenced are not correct. For instance, the path "E:\tools\setup\createlicense.vbs" should be "E:\Open Source Trident\tridentworkflow-62345\tools\setup\createlicense.vbs" #cd E:\Open Source Trident\tridentworkflow-62345\Trident\Product\Setup #make Input Error: Can not find script file "E:\tools\setup\createlicense.vbs". COPYING FILES Invalid drive specification 0 File(s) copied \\\TridentManagedCustomActions.dll ECHO is off. The system cannot find the path specified. Invalid drive specification 0 File(s) copied The system cannot find the path specified. Error in building msi
Jul 19, 2010 at 5:37 AM

Hi Ashish Bhangale,

Can you please try the following steps to build a trident msi:
1. Open command prompt
2. Navigate to root folder of the Trident source code ($/Trident)
3. Run command: .\tools\build\smoke.cmd <product> <buildkind> <buildtype> <buildarch> .
    (Eg. .\tools\build\smoke.cmd product full debug x86)
4. The msi  can be found in the root drive.
    <Drive>:\ builds\product\<New_Build_Number>\setup\<buildtype>

These steps could also be found in Developer On-boarding Guide: http://tridentworkflow.codeplex.com/Project/Download/FileDownload.aspx?DownloadId=129804

Thanks,

Trident support team.

Jul 19, 2010 at 6:06 AM
Thanks for the prompt reply. I think the script does not handle folder name with spaces, so I had to rename the folder. #cd E:\codeplexTrident\tridentworkflow-62345 #.\tools\build\smoke.cmd product full debug x86 "" No system-wide patches. Testing .NET framework 2.0 Build 1655.3 Drop location: \builds\product\1655.3 No system-wide patches. FATAL: perl not found No BBPack specified. Using default source. Launching build 'full' Full build started... ALLUSERSPROFILE=C:\ProgramData AlToolPath=\codeplexTrident\tridentworkflow-62345\tools\build\..\..\public\ext\u rt\4.0Tools ANT_HOME=C:\apache-ant-1.8.0 APPDATA=C:\Users\Administrator\AppData\Roaming AXIS2_HOME=C:\axis2\axis2-1.5.1\ AXIS2_LIB=C:\axis2\axis2-1.5.1\lib BLDDIR=\codeplexTrident\tridentworkflow-62345\tools\build\ Build.Sign=Disabled BuildDrop=\builds\product\1655.3 BUILDERR=1 BuildNumber=1655.3 BuildRoot=\codeplexTrident\tridentworkflow-62345\tools\build\..\.. BuildStage=\codeplexTrident\tridentworkflow-62345\tools\build\..\..\stage BuildTarget=x86 BUILDTARGETDIR=\\ BuildTargetRoot=\codeplexTrident\tridentworkflow-62345\tools\build\..\..\target BuildTracker.BuildShareGroup.DropShare=\builds\product BuildTracker.BuildShareGroup.Product.Name=product BuildType=debug BUILDVERSION=1.2. CATALINA_HOME=C:\apache-tomcat-6.0.26 CCP_DATA=C:\Program Files\Microsoft HPC Pack\Data\ CCP_HOME=C:\Program Files\Microsoft HPC Pack\ CCP_INC=C:\Program Files\Microsoft HPC Pack 2008 SDK\Include\ CCP_JOBTEMPLATE=Default CCP_LIB32=C:\Program Files\Microsoft HPC Pack 2008 SDK\Lib\i386\ CCP_LIB64=C:\Program Files\Microsoft HPC Pack 2008 SDK\Lib\amd64\ CCP_SDK=C:\Program Files\Microsoft HPC Pack 2008 SDK\ CLIENTNAME=BASH-PC CommonProgramFiles=C:\Program Files\Common Files CommonProgramFiles(x86)=C:\Program Files (x86)\Common Files COMPUTERNAME=ASHBHA ComSpec=C:\Windows\system32\cmd.exe DOT=3 FP_NO_HOST_CHECK=NO GENBLDVER=1655 HOMEDRIVE=C: HOMEPATH=\Users\Administrator IDL_DLM_PATH=C:\Program Files (x86)\NCAR\VAPOR\bin;C:\Program Files (x86)\NCAR\V APOR\bin JAVA_HOME=C:\Program Files\Java\jdk1.6.0_17 LOCALAPPDATA=C:\Users\Administrator\AppData\Local LOCTARGET=1033 LOCTARGET_ID=1033 LOCTEXTXML=WixUI_en-us.wxl LOGONSERVER=\\ASHBHA MAKEMSI=\codeplexTrident\tridentworkflow-62345\tools\build\..\..\tools\setup\mak emsi.cmd MAXBUILDS=100 MSBUILD_4_0=\codeplexTrident\tridentworkflow-62345\tools\build\..\..\public\ext\ urt\v4.0.30319\msbuild.exe MYPATH=\codeplexTrident\tridentworkflow-62345\tools\build\ ND_INC=C:\Program Files\Microsoft HPC Pack 2008 SDK\Include\ NUMBER_OF_PROCESSORS=2 OS=Windows_NT Path=C:\Program Files (x86)\NCAR\VAPOR\bin;C:\Program Files\Microsoft HPC Pack 2 008 SDK\Bin\;C:\Program Files\Microsoft HPC Pack\Bin\;C:\Windows\system32;C:\Win dows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Pro gram Files (x86)\Microsoft SQL Server\100\Tools\Binn\;C:\Program Files\Microsoft SQL Server\100\Tools\Binn\;C:\Program Files\Microsoft SQL Server\100\DTS\Binn\; c:\Program Files (x86)\Microsoft SQL Server\90\Tools\binn\;C:\Program Files (x86 )\WinMerge;C:\Program Files\TortoiseSVN\bin;C:\Users\Administrator\Downloads\apa che-maven-2.2.1-bin\apache-maven-2.2.1\bin;C:\Program Files\MySQL\MySQL Server 5 .1\bin;C:\axis2\axis2-1.5.1\bin;C:\Program Files (x86)\WinMerge;C:\apache-ant-1. 8.0\bin;C:\eclipse;C:\Program Files (x86)\Microsoft Visual Studio 2008 SDK\Visua lStudioIntegration\Tools\Sandcastle\ProductionTools\;C:\Program Files (x86)\SSH Communications Security\SSH Secure Shell;"\codeplexTrident\tridentworkflow-62345 \tools\build\\..\sdpack\bin";"\codeplexTrident\tridentworkflow-62345\tools\build \\..\sdpack\bin";"\codeplexTrident\tridentworkflow-62345\tools\build\\..\sdpack\ bin";"\codeplexTrident\tridentworkflow-62345\tools\build\\..\sdpack\bin" PATHEXT=.COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH;.MSC PROCESSOR_ARCHITECTURE=AMD64 PROCESSOR_IDENTIFIER=Intel64 Family 6 Model 26 Stepping 5, GenuineIntel PROCESSOR_LEVEL=6 PROCESSOR_REVISION=1a05 PRODUCTVERSION=1.2 ProgramData=C:\ProgramData ProgramFiles=C:\Program Files ProgramFiles(x86)=C:\Program Files (x86) PROMPT=# PUBLIC=C:\Users\Public PUBLIC_EXT=\codeplexTrident\tridentworkflow-62345\tools\build\..\..\public\ext SESSIONNAME=RDP-Tcp#1 SETUP_PACKAGE_ID=6190672c-9658-490d-baec-a97e10a8433f SETUP_PRODUCT_ID=2814d863-a709-4dc4-9d85-ea550fed3c09 SysPatchRoot=C:\bt\patches\product SystemDrive=C: SystemRoot=C:\Windows TEMP=C:\Users\ADMINI~1\AppData\Local\Temp\3 TITLE=Microsoft Project Trident - A Scientific Workflow Workbench TITLE_SHORT=Trident TMP=C:\Users\ADMINI~1\AppData\Local\Temp\3 URTTARGET_4_0=\codeplexTrident\tridentworkflow-62345\tools\build\..\..\public\ex t\urt\v4.0.30319 USERDOMAIN=ASHBHA USERNAME=Administrator USERPROFILE=C:\Users\Administrator VAPOR_DEBUG=1 VAPOR_HOME=C:\Program Files (x86)\NCAR\VAPOR VAPOR_SHARE=C:\Program Files (x86)\NCAR\VAPOR\share VERBOSE=0 VS100COMNTOOLS=C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\Tools \ VS90COMNTOOLS=c:\Program Files (x86)\Microsoft Visual Studio 9.0\Common7\Tools\ VSSDK90Install=C:\Program Files (x86)\Microsoft Visual Studio 2008 SDK\ windir=C:\Windows Invalid switch - "f". The system cannot find the path specified. *** BUILD FAILED *** # Hi Vinay, Do we need perl? I see that line 6 on getperl.cmd adds sdpack to the path, but I dont think the path is correct because #dir /S *.* | findstr "sdpack" does not return anything. I see getperl.cmd adds "\codeplexTrident\tridentworkflow-62345\tools\build\\..\sdpack\bin";"\codeplexTrident\tridentworkflow-62345\tools\build\\..\sdpack\bin";"\codeplexTrident\tridentworkflow-62345\tools\build\\..\sdpack\bin";"\codeplexTrident\tridentworkflow-62345\tools\build\\..\sdpack\bin" to my PATH variable \codeplexTrident\tridentworkflow-62345\tools\build\\..\sdpack\bin is incorrect for me. Thanks, Ashish Bhangale
Jul 19, 2010 at 6:45 AM

Hi Ashish Bhangale,

One quick question,

Have you installed and copied files for the following softwares?

  1. .net framework 4.0,
  2. Wix 2.0 & 3.0
  3. Enterprise libraray 5.0"

Please refer the Developer On-boarding Guide: http://tridentworkflow.codeplex.com/Project/Download/FileDownload.aspx?DownloadId=129804 for detailed steps.

PLease let me know if yo uneed nay other help.

Thanks,

Trident support team.

Jul 19, 2010 at 6:52 AM
I have not installed Enterprise Library. I did not follow the document, skipped steps and jumped to scripts. I thought if there was an install script which could do most of the installation silently for me. Let me try this tomorrow. Thanks!
Jul 20, 2010 at 6:14 AM
I have .net framework 4.0 installed already, now I added wix2 binaries to path and installed wix3 in addition to Enterprise library. Still I run into errors. #.\tools\build\smoke.cmd product full debug x86 "" No system-wide patches. Testing .NET framework 2.0 Build 1656.0 Drop location: \builds\product\1656.0 No system-wide patches. FATAL: perl not found No BBPack specified. Using default source. Launching build 'full' Full build started... ALLUSERSPROFILE=C:\ProgramData AlToolPath=\codeplexTrident\tridentworkflow-62345\tools\build\..\..\public\ext\urt\4.0Tools ..... windir=C:\Windows Invalid switch - "f". The system cannot find the path specified. *** BUILD FAILED ***
Jul 20, 2010 at 7:38 AM

Hello Ashish,

Could you confirm if the 4.0Tools folder and v4.0.30319 folder are copied under \public\ext\urt ?

If you have all required softwares installed, please follow steps below as a Pre-build operation:

  1. Create a folder called “public” under the root of the TFS workspace. Create a folder “ext” under “public”. ($/Trident/public/ext)
  2. Copy the enterprise library binaries from “%ProgramFiles%\Microsoft Enterprise Library 5.0\Bin” to “$/Trident/public/ext/enterpriselibrary/5.0”
  3. Copy all files from “%ProgramFiles%\MSBuild\Microsoft\Silverlight\v3.0” to “$/Trident/public/ext/Silverlight/v3.0”
  4. Copy the Wix2 binaries from the download location of Wix2 binaries to “$/Trident/public/ext/wix2”
  5. Copy files from Wix3 sdk from the download location of Wix3 binaries to “$/Trident/public/ext/wix3/sdk”
  6. Create a folder “urt” under “ext”. ($/Trident/public/ext/urt). Copy .Net framework 4.0 related binaries from the path “%Windir%\Microsoft.NET\Framework\v4.0.30319” to “$/Trident/public/ext/urt/v4.0.30319”
  7. Copy the 4.0 related binaries from the path “%ProgramFiles%\Microsoft SDKs\Windows\v7.0A\bin\NETFX 4.0 Tools” to “$/Trident/public/ext/urt/4.0Tools”

Please refer to On-Boarding Guide:  http://tridentworkflow.codeplex.com/Project/Download/FileDownload.aspx?DownloadId=129804 for folder structure of 'public' folder and detailed steps.

Let us know if you need any further help.

Thanks,

Trident Support Team

 

Aug 1, 2010 at 7:47 PM

Hey, we followed the steps from the On-Boarding document and we are now able to build Trident from source, Thanks!