Cannot run the Lightweight executor from a network location

May 21, 2011 at 8:51 AM


I am following my own previously written documentation for setting up a lightweight executor for access by several compute nodes. I encounter a new issue, for which the only obvious reason that I can see being moving from XP to Win7.

I can run the lightweight executor fine from the localhost, but if I launch it with the UNC path preceding, I get the error below (*if* I run in debug from VS2010, otherwise it silently fails).

I tried to follow the instructions in, but to no avail. I'll have to work around this one, but has anyone a tip?

Cheers, J-M

System.IO.FileLoadException occurred

  Message=Could not load file or assembly 'file://\\XXXXXX\Trident\Microsoft.Research.DataLayer.DataProviders.Microsoft.dll' or one of its dependencies. Operation is not supported. (Exception from HRESULT: 0x80131515)

 InnerException: System.NotSupportedException
       Message=An attempt was made to load an assembly from a network location which would have caused the assembly to be sandboxed in previous versions of the .NET Framework. This release of the .NET Framework does not enable CAS policy by default, so this load may be dangerous. If this load is not intended to sandbox the assembly, please enable the loadFromRemoteSources switch. See for more information.

May 23, 2011 at 12:41 PM


Thanks for your post.

Can you please suggest us the way, the usage scenario, in which you are executing the LightweightExecutor. We are not able to reproduce this issue at our end.

Support Team